All About Smartphones: Fix "No Service" Problem After Ultrasn0w Update & Evasi0n Jailbreak

Thursday, February 7, 2013

Fix "No Service" Problem After Ultrasn0w Update & Evasi0n Jailbreak

Evasi0n untethered jailbreak of iOS 6 is still one of the best things that have happened in the jailbreak scene since iOS 5.1.1 jailbreak.
While many have quickly jumped and grabbed on the oppurtunity to untether jailbreak their devices before Apple patches again, some have encountered many issues with the jailbroken device.
One is the issue of Cydia shrinking in size while some have the Weather app problem although these abnormalities have been fixed with new release of Evasi0n.

Just today, I tried to untether jailbreak an already Semi-jailbroken iPhone 3GS on iOS 6.0.1 new bootrom, baseband 5.13.04 (downgraded from 06.15.00).
Evasi0n 1.1 noticed that it was jail-broken and advised that I install the untethered jailbreak via Cydia.

I fired up Cydia, allow it to download packages, and then install Evasi0n untethered jailbreak files.
I was asked to upgrade some already installed programs. I Installed other packages including upgrading Ultrasn0w 1.2.7 to 1.2.8. Immediately Ultrasn0w 1.2.7 got upgraded, network bars disappeared and "No Service" was displayed. When you power on your device, Evasi0n will do some work on your device before it boots into the main screen. I was patient and allowed it to complete its untethered jailbreak - and still "No Service"
This network bar issue should only happen when I power on the device without booting tethered.

If you ended up like I described above, this fix should get you back.

Step 1
Launch Cydia and go to Manage>Packages>Ultrasn0w. Click on Modify and then Remove
Also Remove Ultrasn0w fixer in like manner if you have it installed

Step 2.
Since you can't get Ultrasn0w 1.2.7 anymore from Cydia, you will need to download it manually and Install. To do that, click here to download Ultrasn0w 1.2.7. extract to a folder on your desktop when download complete.

Step 3
Download iTool or iFunbox or DiskAid. For this tutorial, i am using iTools.
  • Plug in your device and launch iTools
  • Click FileSystem at the left side of the screen
  • at the top of the screen you will see a search bar, type this into it /var/root/Media/Cydia/AutoInstall
  • A blank page shows up. Click on Upload>file
  • Now select the Ultrasn0w files you deleted and enter. Both files will show up in the empty space
iTools
Step 4
Switch Off and On your device twice. After that your network bars should be up again.
If not, you can go download Ultrasn0w fixer 6.0.1 if you find it.

I hope you do find this tutorial useful. 

65 comments:

  1. Thank you very much for your help, the method worked perfectly but I had to install UltraSn0w Fixer before using the iTools to install UltraSn0w 1.2.7 -- thanks again pal :)

    ReplyDelete
  2. How do I downgrade the modem firmware from 06.15.00 to 5.13.04 on my iphone 3gs? and the link to ultrasn0w 1.2.7 doesn't seem to work it just says there is a problem with the download and loop it back to the original screen. Help?

    ReplyDelete
    Replies
    1. I just checked the link(http://www.mediafire.com/?4b1amdho4ld7ncl) for the ultrasn0w 1.2.7 download and its still valid. Downloaded from it again now.
      To know how to downgrade, follow this link:http://goo.gl/bJQdV

      Delete
  3. Hi I have iphone 4 and BB 01.59.00 and tried the above steps but still have no service

    ReplyDelete
    Replies
    1. Remove the ultrasn0w you downloaded. Reboot phone. Launch Cydia and Install Ultrasn0w fixer. After that reinstall Ultrasn0w 1.2.7. If after installing it still doesn't work, consider updating Ultrasn0w to the latest version via Cydia

      Delete
    2. Hi Akin, Thanks for the quick response. I used Sn0wbreeze to jailbreak IOS6.1.2 all worked ok and then i installed Ultrasn0w 1.2.8 and had no service rebooted etc many time still not working.

      I have tried all the steps above and still no service, please help driving me crazy.

      Delete
    3. Have never used snowbreeze to jailbreak iOS 6.x before. I use evasi0n for ios 6.x jailbreak.
      Also, in the files with the download, mobile substrate is included. Make sure its installed with ultrasn0w 1.2.7 when installing with iTools.
      Furthermore, are you sure your gevey is recent (at least iOS 5.1.1 compatible)

      Delete
  4. ok if i have used Snowbreeze can i re-jailbreak using evasion? yes mobile substrate is installed. Yes ultrasnow 1.2.7 is installed as even when i launch Cydia it tells me that it needs updating.

    my BB is 01.59.00 and last on ios 4.3.3 before updating to 6.1.2.

    When i install the fix either 6.01 or 6.1 (ultrasnow) my iphone just hangs while unlocking.

    I dont not use grevey??
    thanks

    ReplyDelete
    Replies
    1. Okay. Since you don't use Gevey, you won't be ale to unlock your device. Ultrasn0w isn't working for iOS 6.1.2 or 6.1 on your BB yet. There's an issue with it.
      However, since you have an iPhone 4 with such BB, you can do an IMEI unlock because the 2yrs contract from your carrier would have expired and they can unlock it for you.

      Delete
  5. Hi thank you again. Ok do u think there will be a fix fir ultrasnow soon? I have request unlock but will take some time. Is there any way I can downgrade back to iOS 4.3.3 or any other iOS that will give me service?

    ReplyDelete
    Replies
    1. Hopefully there would be a fix for it soon.
      You can only downgrade to iOS 4.3.3 if you have saved your SHSH blobs before you upgraded to 6.1.2.
      Launch Cydia, if your SHSH blobs are saved it will be writen at the top close to the status bar.

      If you have it saved, use Redsn0w to downgrade to 4.3.3
      Also, because you moved directly to 6.1.2 from 4.3.3 you won't be able to downgrade to any iOS version aside from 4.3.3 because of unsaved SHSH blobs for them.

      My advice is that since you have requested for an IMEI unlock,be patient, receive unlock success email, deactivate device with redsn0w and then connect device to iTunes for IMEI activation.

      Delete
  6. Hi,

    I updated my 3gs to ios6.1.2 in error and got my phone deactiviated. I have 3gs and used evais0n to jailbreak ios 6.1.2, getting no signal now. I down loaded ultrasnow 6.1 through cydia and still no luck. My baseband is 05.16.08. Please advise.
    thanking you in advance.

    Shane

    ReplyDelete
    Replies
    1. What's is your Serial Number. Knowing your serial number will help determine if its safe to install iPad baseband (06.15.00). If you install iPad baseband your network signal will pop up. However, if your S/N doesn't support installing iPad baseband, you can downgrade to 5.13.04 baseband.
      To downgrade BB, use can use Redsn0w 0.9.14b2. Follow the link for more info http://goo.gl/uWjpO

      Delete
    2. Sorry, wrong link. This is the correct link: phonegist.blogspot.com/2013/02/how-to-downgrade-iphone-3gs-baseband.html?m=1

      Delete
    3. serial number is 860092F13NP. Do I downlaod redsnow 0.9.14b2 and jailbreak from there ? Or should I use evasi0n ?

      thanks,
      shane

      Delete
  7. Hi,

    I did the downgrade on redsnow jailbreak, "downgrade ipda base" and the firmware on the iphone is still 5.16.08. Where do I go from here ?

    many thanks,
    Shane C

    ReplyDelete
    Replies
    1. Based on your SN, your device chip was manufactured year 2010, week 09. This means that you can safely install iPad baseband. You need to install iPad baseband first then downgrade. So use Redsn0w (latest version 0.9.15b3) to install iPad baseband and then downgrade to ipad baseband again to 05.13.04. Once you are done doing that, you should be able to use ulrasn0w to unlock your device.

      This was the step i used to unlock a 3GS last week

      Delete
    2. A feedback is pending. Where you able to get it done?

      Delete
  8. Hi Akin,

    sorry for the late reply, was in work so only getting to do it now. Worked 100%. The problem I think was I was using redsn0w 0.9.15b1. Can you tell me by "tethered" does this mean each time the phone is powered off then I need to "just boot" on redsnow ? Or is there a an untethered version available ?

    thanks a mill for all your help.

    Your are a pure gent.

    ShaneC

    ReplyDelete
    Replies
    1. Tethered jailbreak means that you would need to connect your device to computer and use redsn0w to "just boot tethered" anytime the device is turned off.
      However, since you are already jailbroken on iOS 6.1.2, just download evasion untethered jailbreak packages from Cydia. Once downloaded, your phone would be rebooted and jailbroken untethered

      Delete
  9. Hi Akin,

    me again, when I went into Cydia and hit the search icon, I then typed in Evasi0n in to search tab and no evasion packages were available, do I need to go into "manage" edit, add and then add in a http/ ??

    thanks
    Shane C

    ReplyDelete
    Replies
    1. Hello Shane,
      Sorry for the late response, had been on site for few days now (networking stuffs).
      To answer your question, please make sure you type Evasi0n and not Evasion. However if that doesn't solve the problem, you can manually add this repo666. ultrasn0w.com/ to your sources like you mentioned above.
      Sorry for the late response again. Hopefully will get a success response from you.
      Ciao

      Delete
  10. hi Aikin
    i have an iphone 3g on 4.2.1 bb5.5.13.04
    i have jailbroken it with redsn0w and downgraded bb from ipad one
    installed ultrasn0w 1.2.7 as you said and still have no service
    what am i doing wrong please???
    maeve

    ReplyDelete
  11. hi
    upgraded my iphone 3gs to 6.1 from 4.1 tru snowbreeze... got it activated but no service. my bb is 6.15... pls help

    ReplyDelete
    Replies
    1. Download Redsn0w 0.9.14b1, extract it, put ur device in dfu mode, click, jailbreak, select downgrade ipad baseband, uncheck install Cydia,check auto boot device, click nex.

      Let redsn0w downgrade the bb and then u can unlock again with ultrasn0w

      Delete
  12. Gotta give major props here. Best fix I've seen, and I've been around the block many times trying to solve this issue. Thanks!

    ReplyDelete
  13. This comment has been removed by the author.

    ReplyDelete
    Replies
    1. Hi,
      I have iphone 4 which is upgraded to 6.1.3 ios. I have jail break it and now it is showing "no service". The original phone was from UK and is now brought to india. Can you please help me to know how would i solve this issue.

      Delete
    2. You need to unlock your phone. IMEI unlock is the best.

      I need more info. Were you using Gevey to unlock? Or Ultrasn0w? Was your baseband preserved after update and jailbreak?

      Delete
    3. Thanks Akin for your quick response!! You are kind and of helping nature.

      I have used redsnow to jailbreak, then for unlocking i was using Ultrosnow. But it isn't helping. My IOS is 6.1.3 and Firmware is 04.12.05

      Let me know if I can solve this as per your instructions.

      Delete
    4. TAs per your baseband,04.12.05, you can't unlock with Gevey or ultrasn0w.

      Your only unlock method is imei unlock.

      Delete
    5. how do i unlock it through imei method??

      Delete
  14. This comment has been removed by the author.

    ReplyDelete
  15. You will request for it. There are many websites that offer such services. Amongs them are www.myimeiunlock.com, unlockboot.com

    They are genuine.

    ReplyDelete
    Replies
    1. Thanx a tonne Akin.. It really helped a lot. I was confused all these days.

      You rock buddy ..!! God Bless ...!!

      Delete
  16. Thanks a lot buddy. Its working as simple as that.

    ReplyDelete
  17. hello, I need some help here..

    I have an iPhone 3GS, iOS 6.1.2, Baseband 05.13.04, new bootrom.. i did what you said and now I have signal, but i can't send text messages, and when someone text me, i receive an empty/blank sms !

    can you help me? thanks

    ReplyDelete
    Replies
    1. This is what you need http://phonegist.blogspot.com/2013/02/fix-iphone-ios-61-unknown-blank.html

      Delete
  18. You are awesome!!! Thank you so very much! Worked like a charm!

    ReplyDelete
  19. Hi buddy,

    I have I phone 3GS ios 5.1.1 just jail break and it's locked with one of our countries carrier i.e Vodafone. I want to use it with Aircel (that's another carrier from our country) and I checked a lot of videos but still it says No Service. I have BB 06.15.00 and I tried Installing Ultrasnow by adding repo666.ultrasn0w.com and also tried iparelhos.com and checked for fixer but iparelhos only shows fixer for ios 6.0 or 6.1. Any help would be appreciated :)

    Cheers,
    Jerin.

    ReplyDelete
    Replies
    1. Helly jerin,
      Download ultrasn0w fixer for iOS 5.1.1 from the link (double click on the text file to reveal the password)
      https://www.dropbox.com/s/iddc5p4681m7mye/UltraSn0w%20FIXER%20for%20iOS%205.1.1.rar

      The file contains the three files you would need. Use the method described in the post to install the files insert substrate and ultrasn0w fixer first, reboot phone, then insert ultrasn0w 1.2.5 into phone again and reboot phone. It should solve the problem.

      Delete
    2. Thank you so much for you reply buddy :D

      Accidentally I restored from Itunes and now it's showing restored to ios 6.1.3 and I got stuck on activation so I hactivated by installing cydia and tried doing Ultrasnow 1.2.8 but still shows no service. Any idea what could be the problem? or do you want me to downgrade to Ios 5.1.1 again and try the above step? Whichever option you tell me, I'll do that :D

      Thanks for your suggestions buddy.
      Cheers
      Jerin.

      Delete
    3. Hello Jerin,
      sorry my reply is coming late. Traveled today.
      Am sure Cydia on its own couldn't hacktivate your device, cos you would need access to the home screen to use Cydia to hacktivate. hence, am not sure what you meant by using cydia to hacktivate.

      Now what you can do is reload iOS 6.1.3 again. This time with the help of sn0wbreeze.

      You would download sn0wbreeze and download iOS 6.1.3 ipsw for your device
      next you would launch sn0wbreeze, select the downloaded ipsw.
      next choose simple mode. This mode would hacktivate, jailbreak and preserve your baseband
      next, a custom IPSW would be made for you and would be saved on your desktop.
      next put your phone in dfu mode and with the help of iReb to be double sure its in dfu mode.
      next launch iTunes, press and hold shift and then click restore
      next you choose the sn0wbreeze created ipsw
      next itunes would restore to ios 6.1.3 and hacktivated and also jailbroken
      next use the cydia to install ultrasn0w and ultrasn0w fixer as explained earlier...

      you can use this tutorial in this link as a guide http://phonegist.blogspot.com/2013/02/gevey-on-ios-61-iphone-4-works.html

      Delete
    4. Hi Akin,

      Thanks for the step by step process. I did as you said. Have ios6.1.3 and downloaded snowbreeze and selected the ipsw 6.1.3 and selected simple mode and then it created the custom firmware on desktop but that point of time, snowbreeze just popped up a message saying it needs to close since it's stopped responding but the custom IPSW was created. I opened Itunes and selected the IPSW and it went through but at the last step when the phone needs to be reboot, it did not reboot so I downloaded Ibooty for ios 6.1.3 for rebooting but it says it's done rebooting but phone not responding to the same. Any idea what the issue might be now?

      And thank you a soo soo soooo much buddy for all your replies. It does help me a lot and I learn a lot of new things :D

      Cheers,
      Jerin.

      Delete
    5. Hi Akin,

      I did the just boot option from redsnow and it started up..It had cydia installed..I downloaded ultrasnow 1.2.7 separately and Itools as well and placed mobile susbstract and Ultrasnow 1.2.7 there where you described and did just boot from redsnow twice but still No Service :( then I also opened cydia and it automatically upgraded mobile sustract and ultrasnow. So just to try I did another just boot option from Redsnow but still no service. Do you know what I'm doing wrong? or is this fault with my Iphone3gs?

      Delete
    6. And bro I also let you know what it shows in About
      Carrier: AIRCEL 14.0
      Model MC131B/A
      Serial Number 880110UY3NP
      Modem Firmware: 05.13.04

      So at last I have given all the information that I have in my phone and what I did haha. So if you have any idea what I did wrong, I can try again. And buddy thank you so much for your support, I'm really glad that you are helping me out with this :D

      Cheers,
      Jerin.

      Delete
    7. Hello Jerin,
      That's a little strange, it should work as you have done. Your device is a new baseband 3GS that's why you needed to boot tethered coz the jailbreak was a tethered jailbreak and any time the phone is switched off, you would need to boot tethered.

      Now, did you at any point in time flash iPad baseband to get your baseband to 6.15.00?

      Delete
    8. Hi Akin,

      No I never flashed baseband. Earlier it was 06.15.00 however when I got Ios 6.1.3 it changed to 05.13.04. I did do the Just boot tether option always once I turn off the phone but still no service. Also tried installing Ultrasnow Fixer for Ios 6.1 as well (just to see if it works :P) and then again did Just boot tether from redsnow but no luck :(

      Delete
    9. One way or the other, the baseband was downgraded to 5.13.04 from 6.15.00 perhaps before you got it. Sn0wbreeze doesn't update baseband so it wasn't the sn0wbreeze that got you there. However, that baseband (5.13.04) is very good to unlock.

      Turn off 3G service, remove SIM, uninstall ultrasn0w, respring your phone, insert sim and see if It works.

      Try that and let's see if it works

      Delete
    10. I did try that as well. I removed Ultrasnow (which is showing 1.2.8) and also removed Ultrasnow Fixer (that I had installed just to see if it does the trick) and restarted springboard and inserted SIM again but It still says No Service :( I think the problem is with the phone (I believe)

      Delete
    11. Anyways buddy. Thank you so much for your support on this. You are a gem of a person :D

      Take care and God Bless you and your family
      Jerin.

      Delete
    12. Sorry, it could be fixed, but as a last resort you could request the IMEI unlock method. That could work.

      Stay good bro and thanks for d prayer.

      Delete
  20. hi can you help please, i have a iphone 36 on 4.2.1 which i flashed to baseband 5.15.04 for the first time and everything went ok except it comes up no service or searching i tried installing ultrasn0w fixer 5.1.1 from smolk ( the only fixer i could find ) and used the tutorial above for ultrasn0w 1.2.7 but still the same, and it sometimes comes up with something about not being activated. could you tell me what im doing wrong please or help in anyway, thanks

    ReplyDelete
  21. hi..Im college student, thanks for sharing :)

    ReplyDelete
  22. I installed ultrasn0w 1.2.7 but its not working! Im on bb 5.13.04 any ideas?

    ReplyDelete
    Replies
    1. Install ultrasn0w fixer first, reboot the phone and then install ultrasn0w 1.2.8

      Delete
    2. Don't forget to reboot the device twice and also put the files in the right directory. Try the steps and turn ON and OFF airplane mode to try forcing the network bars to show

      Delete
  23. thanks a lot working on iphone 3gs

    ReplyDelete
  24. helo, i have iphone 3gs with ios 6.1.6 and baseband 06.15.00 . just wanna ask, can i do all of these steps into my iphone as i hav different type of baseband ..

    ReplyDelete
    Replies
    1. Yes you can. The baseband you have is iPad baseband and it should be able to see signal after applying the tip in the post. However, if it doesn't, you may consider downgrading to a baseband that is workable.

      Delete
  25. Thank you! Thank you! Thank you! Thank you! Thank you! *10000 The only working solution!

    ReplyDelete
  26. thanks this work for me you ROCK!!

    ReplyDelete

There was an error in this gadget

Google+ Followers